Issues using brush ...
 
Notifications

Issues using brush on complex models?  

  RSS

Nathan Chasen
(@nathan-chasen)
New Member Customer
Joined: 11 months ago
Posts: 4
11/11/2019 4:36 pm  

The brush feature seems to be erratic and unpredictable when trying to paint a relatively complex mesh. Examples being, even though i run the brush over an area, only very few of the faces are being colorized no matter how many times I attempt to go over the area.

Is there something I am missing? I have simplified the mesh in these areas as much as possible and am still having the same issue.

Here is a picture of the issue after trying to paint an area.

 


Quote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 1 year ago
Posts: 196
12/11/2019 1:42 pm  
Posted by: @nathan-chasen

The brush feature seems to be erratic and unpredictable when trying to paint a relatively complex mesh. Examples being, even though i run the brush over an area, only very few of the faces are being colorized no matter how many times I attempt to go over the area.

Is there something I am missing? I have simplified the mesh in these areas as much as possible and am still having the same issue.

Here is a picture of the issue after trying to paint an area.

 

Hi Nathan,

Can you please try setting the texture to 4096? This should help. See attached image.


ReplyQuote
Nathan Chasen
(@nathan-chasen)
New Member Customer
Joined: 11 months ago
Posts: 4
12/11/2019 5:36 pm  

Thank you, this definitely helped a lot, but there are still little artifacts of distant areas of the model being colored when coloring one area. Hopefully these little artifacts won't translate to the print. Are there any plans to increase the texture size limit?

 

Also, to test out whether the artifacts transfer to the final model out I tried to slice after coloring one region and the programs keeps freezing. Saving as a .zip also freezes the program. This model has no issue being loaded so it seems odd that it would be a problem on saving and slicing.

This post was modified 11 months ago 4 times by Nathan Chasen

ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 1 year ago
Posts: 196
13/11/2019 2:42 pm  

@nathan-chasen

There isn't a loading/waiting image so it may seem that the application has frozen while it processes your request. Do you ever get a confirmation message that the slice was uploaded to the server? If not, would you mind sending us your obj/png/settings and we'll try it out? info@bigbrain3d.com


ReplyQuote
Nathan Chasen
(@nathan-chasen)
New Member Customer
Joined: 11 months ago
Posts: 4
13/11/2019 2:57 pm  

@bigbrain3d

I've moved on from the brushing idea and just remade the model as individual components from scratch, but I can send you the model. When I say froze I mean the browser crashes the tab to an error screen "Whoops, something went wrong" type of message. The model is pretty large but I will send a google drive link. I don't still have the texture file but I had the issue no matter which part I used the brush on prior to slicing.

 

The model is sent with the subject "Model that freezes simplycolor3d"


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 1 year ago
Posts: 196
15/11/2019 3:17 pm  

@nathan-chasen

I know that we already spoke via email. But I'm posting again here for completeness (minus your content).

"We've checked this model over and there are a few issues with it.
At first netfabb could not open it. If netfabb cannot open it then SimplyColor3D won't be able to open it either. 

We reduced the number of faces from 1.2million to 600K. Then it opened. Models should be less than 100MB.
The base of the model is infinitely thin and cannot be printed.
Much of the details that makes the model have such a high face count are so small that they are lost in the slice preparation anyway. The model could be reduced in size even further without affecting the printable details.

Something that is special about SimplyColor3D is that the texture allows the adding of much detail even if the model doesn't have that detail.
It would be much easier to paint details on if the model if it was simpler.
The reduced model now loads in SimplyColor3D.

Being a little concerned about the quality of the painting, we did the extra step of 'smart unwrapping' the model in Blender. The instructions for this are now in the 'https://docs.google.com/document/d/1x79g7OPH5eK-_tv2Hqg4u8nvNGtUBoZgU2E1H0aZnWo/edit%23&source=gmail&ust=1573833275617000&usg=AFQjCNEZuHt0ub4JUqDsHqSx5qORp_vtU w">SimplyColor3D - Getting started guide'. This model now paints much more smoothly.
Thanks,
BigBrain3D
"

ReplyQuote
Shane G
(@shane-g)
New Member Customer
Joined: 11 months ago
Posts: 4
19/11/2019 10:06 pm  

The instructions for unwrapping dont work. When import obj and after shift ;g; there is no layer option


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 1 year ago
Posts: 196
21/11/2019 2:45 pm  

@shane-g

We've updated the instructions and added images. This should be more clear to follow. If you have further issues then will you please send us (info@bigbrain3d.com) the model and we try it out on our side.


ReplyQuote
Share: