X Motor getting to ...
 
Notifications
Clear all

X Motor getting to hot

Page 1 / 2

Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

Hi guys,

I'm using PrusaSlicer 2.1.1 with P2PP Dev 4.0.8

I'm using the start g-code:

;P2PP BIGBRAIN3D_BLOBSIZE=40
;P2PP BIGBRAIN3D_COOLINGTIME=20
;P2PP BIGBRAIN3D_PURGEPOSITION=253.5
;P2PP BIGBRAIN3D_MOTORPOWER_HIGH=850
;P2PP BIGBRAIN3D_MOTORPOWER_NORMAL=550
;P2PP BIGBRAIN3D_PRIME_BLOBS=2
;P2PP BIGBRAIN3D_ENABLE

 

My X Motor is getting to hot. I plan to test with a lower HIGH value.
Can somebody please tell me what is the default value for the Prusa i3 MK3S? Is it 550 like the NORMAL value?


Quote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

@jens-giesser

The default is 650.

The instructions have been updated to MAX 800 so that may prevent the overheating issue.


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

Thank you for tha answer.

The default is 650 but the NORMAL value is 550???
Why is that?

Where can I get the instructions please?

This post was modified 1 year ago by Jens Giesser

ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@BigBrain3D

I have set the HIGH value now to 650 but the motor is still to hot for my taste. It is better than before but still to hot.
Are you sure that 650 is the default value for the motor power? I can not remember that the motor was getting so hot during a normal single-color print.


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

Look like 535 may be the default. You could also add a small fan to the electronics box.

 


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

This is the current of the extruder. The extruder is known for getting to hot.
I don't think that this is the default value for the x axis.....

How can I find that out? Can I find this value in the gcode anywhere?


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

@jens-giesser

I search the marlin firmware and the default current is not obviously listed.

If you connect a computer to the printer via USB cable -> then connect to the printer with Pronterface or similar 3D printing application -> then issue the command M907 it may output the defaults to the serial window. If not, the command M503 will list all EEPRROM settings and may have it listed.


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

Thank you I will look into that in the next days.
I think it will be a good thing if the NORMAL value and the default value match.

I made some tests. I only use 3 of the 4 springs and a value of 250 is enough to push the arm without slipping.

So I don't think that I'm the only one with this problem and it is better to lower the values in your instructions.


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

@jens-giesser

We look forward to hearing the results of your testing. Thanks for contributing 🙂


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

M907 and M503 are not listing the default motor current. I wrote an email to Prusa support now.
Let's see if I get an answer that way. 


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

Here we go:

https://github.com/prusa3d/Prusa-Firmware/issues/58?fbclid=IwAR27tsXRs8ayflgXfdiKfcCI9xdixTKKcaXjFvp6TExrOVSKZPFAR_lIR_g#issuecomment-286200369

 

DEFAULT_PWM_MOTOR_CURRENT  {270, 830, 450} // {XY,Z,E}
DEFAULT_PWM_MOTOR_CURRENT_LOUD  {540, 830, 500} // {XY,Z,E}

So I will use 540 for the HIGH and NORMAL value.

;P2PP BIGBRAIN3D_BLOBSIZE=40
;P2PP BIGBRAIN3D_COOLINGTIME=20
;P2PP BIGBRAIN3D_PURGEPOSITION=253.5
;P2PP BIGBRAIN3D_MOTORPOWER_HIGH=540
;P2PP BIGBRAIN3D_MOTORPOWER_NORMAL=540
;P2PP BIGBRAIN3D_PRIME_BLOBS=2
;P2PP BIGBRAIN3D_ENABLE

This post was modified 1 year ago by Jens Giesser

ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

@jens-giesser

Thank you for sharing this.


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

I'm testing the values right now in a 10h print. In my oppinion 540 is still a bit to high. The X motor is not hot anymore but it is very warm compared to the Y motor. Maybe 540 is still not the right value....

I will try 400 tomorrow and compare the temp between the X and Y motor.


ReplyQuote
Jens Giesser
(@jens-giesser)
Active Member Customer
Joined: 2 years ago
Posts: 14
Topic starter  

@bigbrain3d

 

I still have no info from Prusa Support about the default value but I'm satisfied with this settings now.
The X and Y motor have the same temperature now.

 

;P2PP BIGBRAIN3D_BLOBSIZE=40
;P2PP BIGBRAIN3D_COOLINGTIME=20
;P2PP BIGBRAIN3D_PURGEPOSITION=253.5
;P2PP BIGBRAIN3D_MOTORPOWER_HIGH=450
;P2PP BIGBRAIN3D_MOTORPOWER_NORMAL=400
;P2PP BIGBRAIN3D_PRIME_BLOBS=2
;P2PP BIGBRAIN3D_ENABLE


ReplyQuote
BigBrain3D
(@bigbrain3d)
Supreme moderator Admin
Joined: 2 years ago
Posts: 324
 

@jens-giesser

Thank you for letting us know 🙂


ReplyQuote
Page 1 / 2
Share: